1. Welcome to FordForumsOnline! Our community is here to help you with any questions you have related to your Ford. If you are looking for a friendly community to hang out with other Ford owners you can look no further than our forums here! Registering is easy and free!

2001 E150 Dash lights stop working

Discussion in 'Ford Vans' started by Brian Watts, Jan 11, 2018.

  1. Brian Watts

    Brian Watts New Member

    Joined:
    Jan 11, 2018
    Messages:
    6
    Likes Received:
    2
    I have a 2001 E150 That I just bought, owner claimed dash lights just quit working

    But odd thing is High beam indicator is backwards (works with high beams OFF)

    And with lights on both turn signal lights go on too (dont flash, just on)

    Weird thing is I turn on the High beams and indicator goes off

    And turn signals work and flash when tuned on as well

    Have not check anything yet but wanted to research it

    I have ordered LED 194 bulbs to replace everything in case problem is the bulbs

    But with Highbeam and turn signal light issues too makes me think it wont be burnt out bulbs and is something else (ground or?)

    Love to hear more input and solutions from you previous posters, did you find your problem??

    Thanks
  2. Dominick 1

    Dominick 1 Well-Known Member Respected Member

    Joined:
    Dec 26, 2014
    Messages:
    2,942
    Likes Received:
    333
    Location:
    Parkersburg Wv
    I would check the wiring that goes to the Multi function switch they have been known to burn out
  3. Dominick 1

    Dominick 1 Well-Known Member Respected Member

    Joined:
    Dec 26, 2014
    Messages:
    2,942
    Likes Received:
    333
    Location:
    Parkersburg Wv
    awww.rockauto.com_info_903_1S3125_1__ra_p.jpg
    Switch
  4. Dominick 1

    Dominick 1 Well-Known Member Respected Member

    Joined:
    Dec 26, 2014
    Messages:
    2,942
    Likes Received:
    333
    Location:
    Parkersburg Wv
    awww.rockauto.com_info_903_6S1094__ra_t.jpg
    Wiring
  5. Action

    Action Moderator Staff Member Respected Member

    Joined:
    Mar 22, 2014
    Messages:
    6,512
    Likes Received:
    651
    Location:
    Phoenix, AZ 85008
    Welcome to the FFO!

    I suspect you have a ground issue with the instrument cluster or printed circuit for the instrument cluster illumination.

    The high beam indicator and turn signal lights in the instrument cluster are on separate circuits that are not grounded at the instrument panel. Possible the turn signal multi-function switch is an issue for those pieces.

    Also replacing turn signal bulbs in the turn signal circuit with LED bulbs may stop the turn signals from flashing. The turn signal flasher works based on current draw. Since LEDs draw less current the flasher may not heat up and break the circuit to flash.

    >>>>>>>>>>>> Action
  6. Brian Watts

    Brian Watts New Member

    Joined:
    Jan 11, 2018
    Messages:
    6
    Likes Received:
    2
    Thanks everyone

    All good suggestions and I will check them and see if I can narrow it down

    I will also come back and post conclusion to hopefully help someone else down the road
    Action likes this.
  7. Action

    Action Moderator Staff Member Respected Member

    Joined:
    Mar 22, 2014
    Messages:
    6,512
    Likes Received:
    651
    Location:
    Phoenix, AZ 85008
    ^^^^ That truly does help and is a pay it forward type of thing.

    >>>>>>>>>>>>>>>>>>>>>>>Action
  8. Brian Watts

    Brian Watts New Member

    Joined:
    Jan 11, 2018
    Messages:
    6
    Likes Received:
    2
    Absolutely Action

    I appreciate your members take the time to share their knowledge and take the time to try and help me

    Hope it works and of course I will return the favor

    Appreciate everyone taking the time , seriously!
    Action likes this.
  9. Brian Watts

    Brian Watts New Member

    Joined:
    Jan 11, 2018
    Messages:
    6
    Likes Received:
    2
    Where can I get a good wire schematic with fuse layouts for my 2001 E150?
  10. Action

    Action Moderator Staff Member Respected Member

    Joined:
    Mar 22, 2014
    Messages:
    6,512
    Likes Received:
    651
    Location:
    Phoenix, AZ 85008
  11. Brian Watts

    Brian Watts New Member

    Joined:
    Jan 11, 2018
    Messages:
    6
    Likes Received:
    2
    Very appreciated thanks, bought and on the way

    Should be helpful

    Thanks again :)
  12. Brian Watts

    Brian Watts New Member

    Joined:
    Jan 11, 2018
    Messages:
    6
    Likes Received:
    2
    Looks like others are having the same problem

    My heater/AC panel lights still work

    Gonna try and get in there and try some of the ideas shared here

    http://www.fordforumsonline.com/threads/97-e350-dash-lights-are-not-working.3293/

Share This Page