1. Welcome to FordForumsOnline! Our community is here to help you with any questions you have related to your Ford. If you are looking for a friendly community to hang out with other Ford owners you can look no further than our forums here! Registering is easy and free!

Loss of power

Discussion in 'Ford Vans' started by Awjunior, Feb 11, 2018.

  1. Awjunior

    Awjunior New Member

    Joined:
    Feb 11, 2018
    Messages:
    4
    Likes Received:
    0
    I have a 1986 Ford e150 5.0 Econoline van I'm experiencing a loss of power or hesitation in the throttle I cannot think of what else I can replace I have done everything from spark plugs wires rotor distributor map sensor throttle positioning unit new mufflers and exhaust new injector and I'm clueless can anybody help I'm also experiencing a backfire at times it idles well but as soon as I go to pull it out of the driveway I lose power can anybody help
  2. Action

    Action Moderator Staff Member Respected Member

    Joined:
    Mar 22, 2014
    Messages:
    6,245
    Likes Received:
    617
    Location:
    Phoenix, AZ 85008
    Welcome to the FFO!

    Post mileage.
    Post vacuum reading on warm engine at idle.
    When were the air filter and fuel filters last replaced?
    Have you adjusted base ignition timing?
    Is the check engine light on?

    >>>>>>>>>>>Action
  3. Awjunior

    Awjunior New Member

    Joined:
    Feb 11, 2018
    Messages:
    4
    Likes Received:
    0
  4. Awjunior

    Awjunior New Member

    Joined:
    Feb 11, 2018
    Messages:
    4
    Likes Received:
    0
    I've put off the timing because I can't find the marks the check engine light is not on the fuel filters and air filters and pretty much everything I said I've replaced has been replaced with in the last three miles it starts great idles fine no check engine light so I was trying to not mess with the timing because it's a pain in the ass to see the marks and I can't find them keep in mind I'm just a backyard mechanic I have not a lot of clue what I'm doing I will check the vacuum pressure
  5. Dominick 1

    Dominick 1 Well-Known Member Respected Member

    Joined:
    Dec 26, 2014
    Messages:
    2,827
    Likes Received:
    319
    Location:
    Parkersburg Wv
    Welcome to the Forum
    Have you checked the throttle body mounting gasket for separation in the middle?
    [​IMG]
  6. Awjunior

    Awjunior New Member

    Joined:
    Feb 11, 2018
    Messages:
    4
    Likes Received:
    0
    Yes when I replaced the throttle positions unit I also cleaned the throttle body
  7. Dominick 1

    Dominick 1 Well-Known Member Respected Member

    Joined:
    Dec 26, 2014
    Messages:
    2,827
    Likes Received:
    319
    Location:
    Parkersburg Wv
    Do you have dual tanks?

Share This Page