Ford Automobiles banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Have an 04 explorer that only blows from the defroster and will not blow from the vents or floor. Had the blend door acuator replaced a year and a half ago at a dealership. Took it back there today and was told the blend door hing was bad and needed to be replaced and would cost $970 or I could purchase the heater box and they could take out the pin on the new one and install in my heater box for $490 to save on labor. Does this sound like the real problem here and how hard is it to replace? I'm pretty mechanically inclined and have done several engine overhauls on older cars without all the electronics. Is this something I would be able to do?

Thanks
 

·
Registered
Joined
·
944 Posts
Steve, I would like you to check for available vacuum for the HVAC. You may have a broken plastic line, or leaking check valve. If the vacuum under the hood is OK, then pull out the HVAC controls and check for available vacuum there. Here is why: The temperature blend door you are describing is positioned by an electric actuator. And, they certainly have their issues.. However the airflow mode doors are positioned by vacuum actuators. In the absence of vacuum, all resulting air flow defaults to defrost. So check the vacuum first. Then we can talk about whether pulling the dash is even necessary. Please get back to us!
 

·
Registered
Joined
·
4,352 Posts
1,3,12, 15, and 24 are vacuum actuators.
Here are pictures of a couple of mine in my windstar.
 

Attachments

1 - 5 of 5 Posts
Top