Ford Automobiles banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My wiper blades will not turn off. They run how they are supposed to when they are on, but when I turn them off, they just randomly come on. Sometimes fast, somtimes slow. What and where is the first thiing I should check.
 

·
Registered
Joined
·
659 Posts
Hey there Jjohnson2198,

I would start by checking the Wiper On/Off Relay in the Battery Junction Box, checking Ground G106, checking the fuses in both the BJB and CJB and finally checking the Multifunction Switch itself.

This is the Forums "How To" on the subject of checking fuses 'n relays.

http://www.fordforumsonline.com/forum/electrical-lighting/128-howto-check-your-fuses.html

http://www.fordforumsonline.com/forum/electrical-lighting/144-howto-check-relay.html

Attached is wiring diagram for the wipers on your Windstar.

Hope this helps.
 

Attachments

·
Registered
Joined
·
4,352 Posts
Wow! The only additional information that can be added is the location of G106.

I only have info for a 2000 windstar and it says that the wiper motor goes to G101 which is located driver's side front engine compartment. I don't have a location for G106
 

·
Registered
Joined
·
659 Posts
Wow! The only additional information that can be added is the location of G106.
Oops, my bad......Lower Left Front of the Engine Compartment.
I only have info for a 2000 Windstar and it says that the wiper motor goes to G101 which is located driver's side front engine compartment.
Wow! Now, that's weird.....This is the 2000 Windstar wiper wiring diagrams I have for both a 3.0L and 3.8L and it shows G106 too... Huh?
 

Attachments

1 - 4 of 4 Posts
Top