Ford Automobiles banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey I have a 2006 ford five hundred and one day the engine started shaking and the check engine light came on and the air conditioner stopped working. The fan works but the air conditioner wont blow out real cold air. So i took it to a place that will check it for u for free. its a transmission place so they didnt know that much for sure but they pulled this code up. it was p0351 and they wrote beside that ignition coil and below that they wrote (A) pri/sec circuit fault. They said they think that it needs an ignition coil replaced but theyre not for sure cause they only deal with transmissions and there wasn't anything wrong with my transmission. Can anyone help?
 

·
Registered
Joined
·
623 Posts
With a misfire on that model it can disable the ac. That is a circuit code and may or may not need a coil. Unfortunately the Ford site is down.Does the vehicle always run bad (miss)?

FMCDealer.com (and its affiliates, i.e. MCDistributor, Quicklane, Export Operations, etc.) is unavailable due to technical difficulties or scheduled maintenance. We will restore access in either event as soon as possible. This message will be removed when functionality has been restored.
 

·
Banned
Joined
·
4 Posts
Ouch! Hope that you get your Ford2006 fixed asap. Had the same problem before but the casa had it fixed since it was under insurance.
 

·
Registered
Joined
·
104 Posts
If it shakes at idle then this will work in park, if not then you'll have to set the parking brake and chock the wheels and put it in drive. That should make it act up.

Now disconnect you coils one by one. (not from the spark plug) There should be some quick clips. Each time it should do the same thing, get worse. Only leave unplugged for a few seconds. So if you manage to get through all of them with no change then you can rule out a coil. Visa versa, if you find that one that makes no change in performance, that will be your culprit.
 
1 - 5 of 5 Posts
Top