Ford Automobiles banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 99 expedition 5.4L engine. It was running fine 2 years ago, when it developed a large trans fluid leak that made it undrivable. I did not have the money to fix and had 2 other trucks, so I let it sit.

I still dont have much $$ but want to get it going again, it only has 80l miles.

Now the engine will not start, and I do not hear the fuel pump noise at all.

It will start with a little starting fluid and runs for a few seconds til the starting fluid is used up.

I switched out the fuel pump relay and fuse with another and still no noise or start without fluid.

Does it sound like I need a new pump ???
that is beyond me to do, any idea what a shop would charge ??

is there any way to use an aftermarket pump that does not need to be in the tank??

Of course I will still have a leaking trans to worry about, not sure what that will cost.

thanks for any advise
 

·
Registered
Joined
·
1,755 Posts
Labor calls for 2.2 hours and the current lis on the pump from Ford is 470.00. I am sure you can get a pump for less than that at an aftermarket parts place. As for putting one outside the tank that won't work at all.
 

·
Registered
Joined
·
623 Posts
try haveing someone smack with a rubber mallet the bottom of the fuel tank while you cycle the key on and off.
 

·
Registered
Joined
·
10 Posts
The fuel pump change isn't that difficult. I did a video on YouTube of how to change it. You gotta drop the tank first. It took me a couple hours to do but I was joking around and goofing off too while doing it.
 
1 - 6 of 6 Posts
Top