Ford Automobiles banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2005 Ford 500 that is just about out of Warranty. One day my wife was driving home and she called me and told me the car stalled while she was leaving a light at an intersection. Luckily she was able to coast into a parking lot. On the way to pick her up, she called and said she restarted it, so I drove it home. Later that week, it did it to me driving into the office, and the digital readout said FailSafe Mode, and this time the check engine light came on, but the car didn't stall, it was actually idling, I just couldn't go anywhere. I checked the codes, sorry don't remember the #'s, but it was throwing 2 codes, one I don't recall, and the other was forced idle. The First led me to believe the issue was with the Throttle Body and of course, this part wasn't under warranty. After tracking down this back ordered part, I found one, installed it and 5 days later it did it again, sometimes 8 times just driving around town. This time, I took it in to the dealer on 4/17 and they tell me that it's a throttle body issue and they replaced the one I installed saying it was a defective part and that they have had issues with these from the parts Manufacturer. I got the car back on 4/27 (10 days later!) and on 5/4, it did it again on my wife. I took it to the Dealer and they tell me there are no codes and they don't see any issues. Now I'm getting a little pissed here...Anyone out there have any ideas what I need to do!?!?!
 
1 - 2 of 2 Posts
Top