Ford Automobiles banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Haveing problem with these codes setting. 2005 Ford expidition. 5.4 it quit and had to change the fuel driver module with fuses to get it home. I have replaced the fuel pressure sensor, fuel driver module, altanator checked good, maf has been changed, changed fuse panel. Any ideas? Runs great with fuses in place of fuel driver module but with fuel driver module in it idles fine but stalls on exceleration. Checked wiring ohemed every thing I could think of. Found Nothing. Anybody got any ideas?
2005 Expedition 5.4



Current Fault Log
------------------
ECU reports no current faults

Pending Fault Log
------------------
P0193: Fuel Rail Pressure Sensor Circuit High Input
P0453: Evaporative Emission Control System Pressure Sensor High input

Historic Fault Log
------------------
ECU reports no historic faults
Other discovered fault codes
(possibly pending, current or manufacturer specific)
----------------------------------------------------
P1000: [Ford] OBD-II Monitor Testing Incomplete
[Mazda] OBD II Monitor Testing Not Completed

P1233: [Ford] Fuel Pump Driver Module off-line
[Mitsubishi] TPS(main) plausibility
 

·
Administrator
Joined
·
15,394 Posts
There were issues with the fuel pump driver module. It was mounting on the left rear frame rail and would pick up dirt and debris. Then corrode causing issues with the module operation. And you said you replaced yours.

Does your scan tool read fuel pressure that the PCM sees?
How do you have fuses connected by-passing the driver module?
Also when was the fuel filter last replaced?

Action
 

·
Administrator
Joined
·
15,394 Posts
Text Floor plan Diagram Circuit component Passive circuit component


I believe this is the correct wiring for your vehicle.

Action
 

·
Administrator
Joined
·
15,394 Posts
The module varies the voltage to the pump to deliver different pump pressures.
If you are by-passing the driver module, basically you are sending full voltage to the pump for full pressure.

Possible issues -
Weak pump
Fuel line restriction - how's the filter?
Or some other concern

With module in, fuel pressure reading would be a relevant piece of data to have. I would want to see pressure of 30PSI minimum with engine running. I believe this to be the correct spec:
key on, engine off 35-45 psi
Engine running: 28-45 psi

You may be running out of fuel on acceleration.

Action
 
1 - 4 of 4 Posts
Top