Ford Automobiles banner

1 - 7 of 7 Posts

·
Registered
2003 Ford Expedition Eddie Bauer
Joined
·
4 Posts
Discussion Starter #1
Hi and I just recently got a 2003 Ford expedition Eddie Bauer and I use the heater in the front or back it does not blow hot and it leaks coolant from underneath the passenger side line running by the transmission above the muffler how do I fix this or help repair bypass if anybody knows thank you
 

·
Super Moderator
Joined
·
14,152 Posts
Welcome to the FFO!

The leak is likely from the heat core. If you by-pass it you have no heat at all.

Action
 

·
Registered
2003 Ford Expedition Eddie Bauer
Joined
·
4 Posts
Discussion Starter #3
It already has no heat front or back. Need to find away to add a quick connection or splice if any one has ideas
 

·
Super Moderator
Joined
·
14,152 Posts
There are two hoses that go from the engine to the heater core. You could remove from the engine compartment and then connected to each other.

Same for rear heat if so equipped.

Action
 

·
Registered
2003 Ford Expedition Eddie Bauer
Joined
·
4 Posts
Discussion Starter #5
Ok so if I do that will my heat start working again ? And will I b able to put coolant in? If so what kind will it take.
 

·
Super Moderator
Joined
·
14,152 Posts
No
Yes
And put coolant as directed by the owners manual. That changed over the years and it is important not to mix coolant types. Also coolant has a service life. Usually 3 years. After 3 years the coolant should be drained and new coolant be installed.

To restore heat, the heater core needs to be replaced.

Action
 

·
Registered
2003 Ford Expedition Eddie Bauer
Joined
·
4 Posts
Discussion Starter #7
Thank you for this info. It has been very helpful
 
1 - 7 of 7 Posts
Top