No power | FordForumsOnline.com
  1. Welcome to FordForumsOnline! Our community is here to help you with any questions you have related to your Ford. If you are looking for a friendly community to hang out with other Ford owners you can look no further than our forums here! Registering is easy and free!

  1. Ashley8824

    Ashley8824 New Member

    Joined:
    Jun 26, 2020
    Messages:
    2
    Likes Received:
    0
    I have a 1997 Ford e150 van ran great when we got it moved it in the yard to clean it out well plugged the tv into the power port to see if it worked the van would no longer start just clicking. Replaced the battery starter and starter Solenoid now I have no power in the van at all no light nothing. How can I fix this?
  2. Action

    Action Moderator Staff Member Respected Member

    Joined:
    Mar 22, 2014
    Messages:
    12,644
    Likes Received:
    1,467
    Location:
    Phoenix, AZ 85008
    Welcome to the FFO!

    Sounds like the battery is low or dead.
    Put a charger on the battery
    Make sure the battery cable ends to the battery terminals are clean and tight.

    >>>>>>>Action
  3. Ashley8824

    Ashley8824 New Member

    Joined:
    Jun 26, 2020
    Messages:
    2
    Likes Received:
    0
    It’s a brand new battery testing at full charge
  4. Action

    Action Moderator Staff Member Respected Member

    Joined:
    Mar 22, 2014
    Messages:
    12,644
    Likes Received:
    1,467
    Location:
    Phoenix, AZ 85008
    What is the voltage across the battery?
    What is the voltage at the starter relay?

    >>>Action
  5. Action

    Action Moderator Staff Member Respected Member

    Joined:
    Mar 22, 2014
    Messages:
    12,644
    Likes Received:
    1,467
    Location:
    Phoenix, AZ 85008
    a393f67a7f52faff58940dd18c9e1ecc.jpg

Share This Page